Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 17, 2025 - 13:00 UTC
Scheduled
The registry for .ag, .bz, .lc, .me, .mn, ,pr, .sc, and .vc domains will be undergoing maintenance. Expect an inability to manage, register, or transfer domains with these extensions.
Posted Jun 12, 2025 - 21:31 UTC
This scheduled maintenance affected: Domains (Domain management).